Are you the publisher? Claim or contact us about this channel


Embed this content in your HTML

Search

Report adult content:

click to rate:

Account: (login)

More Channels


Channel Catalog


Channel Description:

Get fast help and free support for Microsoft Dynamics AX from qualified experts in the official Microsoft Dynamics AX forum.

older | 1 | .... | 172 | 173 | 174 | (Page 175) | 176 | 177 | 178 | .... | 892 | newer

    0 0

    Hi all,

    We implemented a security policy where all users are not allowed to delete a document reference of a certain type. This workes fine.

    There is an exception where the document reference must be deleted by using x++ code.

    Also when the AX logic tries to delete the record, the policy is enforced and we get the error that it is not allowed to delete this document reference.

    Can anyone tell me if and how it is possible to make an exception for this policy when using x++ code?


    0 0

    Hello,

    I try to add same webparts to the enterprise portal of dax 2009.

    The Dynamics User Control Webpart "customers" works fine, for example. The customers are displayed in a grid.

    But now I want to add the webpart "EPProjTimeSheet". This webpart is always hidden. If I uncheck the checkbox "hidden" in the webpart propertiers, the checkbox is set again after refresh. Other webparts are always hidden, too.

    My testuser has delete permissions to all security keys.

    Can anyone help me?

    Thank you for your help...

    Regards,
    Frank


    0 0

    When I create a new company, some of the data from CEU company is being copied onto the new company (Example, workers data under Human resources module) which I don't want since I need to do the setup from the scratch and also new data needs to be entered. So, is there a way to create a new company with blank data?


    0 0

    When I tried to install AOS component to different server after installing DB component to DB Server,
    Installation Report shows success but AOS service cannot start.

    Here is our setup information.

    • DB Server (Active-Passive by WSFC)
      • WIndows Server 2008 R2 (Microsoft Windows NT 6.1.7601 Service Pack 1 (64 bit))
      • SQL Server 2012
      • Dynamics AX 2012 R2 (AxSetup version number: 6.2.158.0)
    • AOS Server
      • WIndows Server 2008 R2 (Microsoft Windows NT 6.1.7601 Service Pack 1 (64 bit))
      • Dynamics AX 2012 R2 (AxSetup version number: 6.2.158.0)

    I checked MSDN then verified firewall port between AOS and DB(open port 1433), also check SQL Server Account account permission and local machine user group but issue is not solved.
    http://technet.microsoft.com/EN-US/library/aa496457.aspx

    Sorry for long post but we are puzzled.
    Here is the log file.

    <Install Log>

    2013-04-19 23:16:09Z    === Setting up Application Object Server (AOS) ===

    2013-04-19 23:16:09Z    Adding account 'DOMAIN\AOS-SERVER-SERVICEACCOUNT' as a login in Microsoft SQL Server.

    2013-04-19 23:16:09Z    Creating stored procedures for remote sql server. LoginName: 'DOMAIN\AOS-SERVER-SERVICEACCOUNT'.

    2013-04-19 23:16:09Z    Creating stored procedure 'CREATETEMPDBPERMISSIONS_AOS-SERVER_01'.

    2013-04-19 23:16:09Z    Creating stored procedure '[dbo].[CREATESERVERSESSIONS]'.

    2013-04-19 23:16:10Z    Creating stored procedure '[dbo].[CREATEUSERSESSIONS]'.

    2013-04-19 23:16:10Z    Setup cannot get SYSTABVERSION value from SQLSYSTEMVARIABLES table.

    2013-04-19 23:16:10Z    Invalid object name 'dbo.SQLSYSTEMVARIABLES'.

    2013-04-19 23:16:10Z    Creating stored procedure '[dbo].[getNumInternal]'.

    2013-04-19 23:16:10Z    Creating stored procedure '[dbo].[sp_GetNextRecId]'.

    2013-04-19 23:16:10Z    isolation level = read committed snapshot

    2013-04-19 23:16:10Z    Adding account 'DOMAIN\AOS-SERVER-SERVICEACCOUNT' as a login in Microsoft SQL Server.

    2013-04-19 23:16:10Z    Adding account 'DOMAIN\AOS-SERVER-SERVICEACCOUNT' as a login in Microsoft SQL Server.

    2013-04-19 23:16:10Z    Granting AOS account access to database MicrosoftDynamicsAX_model on server DB-SERVER

    2013-04-19 23:16:10Z    Granting AOS account access to database MicrosoftDynamicsAX on server DB-SERVER

    2013-04-19 23:16:10Z    Granting AOS account access to database MicrosoftDynamicsAXBaseline on server DB-SERVER

    2013-04-19 23:16:10Z    Common Property Install Path set to 'C:\Program Files\Microsoft Dynamics AX\60'.

    2013-04-19 23:16:10Z    Installation Path retrieved from registry. Value: 'C:\Program Files\Microsoft Dynamics AX\60'

    2013-04-19 23:16:11Z    Setting up rights for the AOS service account 'DOMAIN\AOS-SERVER-SERVICEACCOUNT' to access the application files at: C:\Program Files\Microsoft Dynamics AX\60\Server\MicrosoftDynamicsAX\bin\Application

    2013-04-19 23:16:11Z    Common Property Install Path set to 'C:\Program Files\Microsoft Dynamics AX\60'.

    2013-04-19 23:16:11Z    Installation Path retrieved from registry. Value: 'C:\Program Files\Microsoft Dynamics AX\60'

    2013-04-19 23:16:11Z    Creating AOS registry settings.

    2013-04-19 23:16:11Z            The localized name for the BUILTIN\USERS account has been identified as 'BUILTIN\Users'.

    2013-04-19 23:16:11Z    Finished creating AOS registry settings.

    2013-04-19 23:16:11Z    Running Msiexec.exe with these parms:  /i "F:\MSI\ObjectServer64\ObjectServer64.msi" /qb! /l*v "C:\Program Files\Microsoft Dynamics AX\60\Setup Logs\2013-04-19 23-13-41\ObjectServer64 Log.txt" DIRECTEXECUTE=1 /norestart TRANSFORMS=:Instance01 MSINEWINSTANCE=1 INSTALLDIR="C:\Program Files\Microsoft Dynamics AX\60\Server" AOSSTART="1" AOSACCOUNTPASSWORD="********" BYPASSWARNINGS="0"

    2013-04-19 23:16:11Z    Running synchronously.

    2013-04-19 23:17:17Z    Common Property Install Path set to 'C:\Program Files\Microsoft Dynamics AX\60'.

    2013-04-19 23:17:17Z    Installation Path retrieved from registry. Value: 'C:\Program Files\Microsoft Dynamics AX\60'

    2013-04-19 23:17:17Z    Following are messages from the MSI actions log file Microsoft.Dynamics.Setup.AosServer.InstallLog, which could include earlier messages, (check the date):

    2013-04-19 23:17:17Z            Installing assembly 'C:\Program Files\Microsoft Dynamics AX\60\Server\MicrosoftDynamicsAX\Bin\Microsoft.Dynamics.Setup.AosServer.dll'.

    2013-04-19 23:17:17Z            Affected parameters are:

    2013-04-19 23:17:17Z               aosinstancename = MicrosoftDynamicsAX

    2013-04-19 23:17:17Z               bypasswarnings = 0

    2013-04-19 23:17:17Z               assemblypath = C:\Program Files\Microsoft Dynamics AX\60\Server\MicrosoftDynamicsAX\Bin\Microsoft.Dynamics.Setup.AosServer.dll

    2013-04-19 23:17:17Z               aosport = 2712

    2013-04-19 23:17:17Z               aosexe = Ax32Serv

    2013-04-19 23:17:17Z               bindir = C:\Program Files\Microsoft Dynamics AX\60\Server\MicrosoftDynamicsAX\Bin\#

    2013-04-19 23:17:17Z               aosinstancenum = 01

    2013-04-19 23:17:17Z               installtype = notransaction

    2013-04-19 23:17:17Z               logfile = C:\Program Files\Microsoft Dynamics AX\60\Server\MicrosoftDynamicsAX\Bin\Microsoft.Dynamics.Setup.AosServer.InstallLog

    2013-04-19 23:17:17Z               aosnettcpport = 8201

    2013-04-19 23:17:17Z               aoswsdlport = 8101

    2013-04-19 23:17:17Z               setuplanguage =

    2013-04-19 23:17:17Z               uilevel = 3

    2013-04-19 23:17:17Z               action = install

    2013-04-19 23:17:17Z               aosaccount = DOMAIN\AOS-SERVER-SERVICEACCOUNT

    2013-04-19 23:17:17Z           

    2013-04-19 23:17:17Z            >>Install: AOS Server Start 2013/04/19 23:17:14

    2013-04-19 23:17:17Z            >>Install: Generating firewall rule name: 'Dynamics AX 6.0 - MicrosoftDynamicsAX (RPC)'

    2013-04-19 23:17:17Z            >>Install: Port '2712' opened by adding rule 'Dynamics AX 6.0 - MicrosoftDynamicsAX (RPC)'.

    2013-04-19 23:17:17Z            >>Install: Generating firewall rule name: 'Dynamics AX 6.0 - MicrosoftDynamicsAX (NetTCP)'

    2013-04-19 23:17:17Z            >>Install: Port '8201' opened by adding rule 'Dynamics AX 6.0 - MicrosoftDynamicsAX (NetTCP)'.

    2013-04-19 23:17:17Z            >>Install: Generating firewall rule name: 'Dynamics AX 6.0 - MicrosoftDynamicsAX (WSDL)'

    2013-04-19 23:17:17Z            >>Install: Port '8101' opened by adding rule 'Dynamics AX 6.0 - MicrosoftDynamicsAX (WSDL)'.

    2013-04-19 23:17:17Z            >>Install: netsh.exe http show urlacl url=http://+:8101/DynamicsAx/Services/

    2013-04-19 23:17:17Z            >>Install:

    2013-04-19 23:17:17Z            URL Reservations:

    2013-04-19 23:17:17Z            -----------------

    2013-04-19 23:17:17Z           

    2013-04-19 23:17:17Z           

    2013-04-19 23:17:17Z           

    2013-04-19 23:17:17Z           

    2013-04-19 23:17:17Z           

    2013-04-19 23:17:17Z           

    2013-04-19 23:17:17Z            >>Install: netsh.exe http add urlacl url=http://+:8101/DynamicsAx/Services/ user="DOMAIN\AOS-SERVER-SERVICEACCOUNT"

    2013-04-19 23:17:17Z            >>Install:

    2013-04-19 23:17:17Z            URL reservation successfully added

    2013-04-19 23:17:17Z           

    2013-04-19 23:17:17Z           

    2013-04-19 23:17:17Z           

    2013-04-19 23:17:17Z           

    2013-04-19 23:17:17Z           

    2013-04-19 23:17:17Z            >>Install: AOS Server End   2013/04/19 23:17:14

    2013-04-19 23:17:17Z           

    2013-04-19 23:17:17Z           

    2013-04-19 23:17:17Z           

    2013-04-19 23:17:17Z           

    2013-04-19 23:17:17Z           

    2013-04-19 23:17:33Z     ******************************************************************************************************

     

    2013-04-19 23:17:33Z    Component installation task stopped due to an error.

     

    2013-04-19 23:17:33Z     ******************************************************************************************************

    2013-04-19 23:17:33Z     ******************************************************************************************************

     

    2013-04-19 23:17:33Z    Cannot start service AOS60$01 on computer '.'.

     

    2013-04-19 23:17:33Z     ******************************************************************************************************

    2013-04-19 23:17:33Z     ******************************************************************************************************

     

    2013-04-19 23:17:33Z    System.InvalidOperationException: Cannot start service AOS60$01 on computer '.'. ---> System.ComponentModel.Win32Exception: This version of %1 is not compatible with the version of Windows you're running. Check your computer's system information to see whether you need a x86 (32-bit) or x64 (64-bit) version of the program, and then contact the software publisher

    2013-04-19 23:17:33Z       --- End of inner exception stack trace ---

    2013-04-19 23:17:33Z       at System.ServiceProcess.ServiceController.Start(String[] args)

    2013-04-19 23:17:33Z       at Microsoft.Dynamics.Setup.Components.Aos.StartStopService(Boolean start, Boolean setErrorOnException, Boolean waitForFinish)

    2013-04-19 23:17:33Z       at Microsoft.Dynamics.Setup.Components.Aos.PerformPostInstallActions()

    2013-04-19 23:17:33Z       at Microsoft.Dynamics.Setup.Support.SetupQueue.AOSInstaller.PerformWork()

    2013-04-19 23:17:33Z       at Microsoft.Dynamics.Setup.Support.SetupQueue.InstallationClass.DoWork(Object sender, DoWorkEventArgs e)

    2013-04-19 23:17:33Z       at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)

     

    2013-04-19 23:17:33Z     ******************************************************************************************************

    2013-04-19 23:17:33Z     ******************************************************************************************************

     

    2013-04-19 23:17:33Z    This version of %1 is not compatible with the version of Windows you're running. Check your computer's system information to see whether you need a x86 (32-bit) or x64 (64-bit) version of the program, and then contact the software publisher

     

    2013-04-19 23:17:33Z     ******************************************************************************************************

    2013-04-19 23:17:33Z     ******************************************************************************************************

     

    2013-04-19 23:17:33Z    System.ComponentModel.Win32Exception: This version of %1 is not compatible with the version of Windows you're running. Check your computer's system information to see whether you need a x86 (32-bit) or x64 (64-bit) version of the program, and then contact the software publisher

     

    2013-04-19 23:17:33Z     ******************************************************************************************************

    2013-04-19 23:17:34Z    S260FinishedInfo


    0 0

    I am performing an in place upgrade to R2 and was wondering if the R2 cumulative update 1 can be applied at the same time as the AX 2012 R2 upgrade by adding it to the Updates folder in the R2 installation files.


    0 0
  • 04/24/13--08:54: Production Cube Error
  • hello guys,

    i get this error when i process the production cube, anyone has heard about it or dealed with it?

    Errors in the OLAP storage engine: An error occurred while processing the 'Cost calculation' partition of the 'Cost calculation' measure group for the 'Production cube' cube from the Dynamics AX Abril database.

    thanks for your help


    0 0

    Hi all,

     

    I came accross something a little strange. In one customer for all the batch process when you try to setup a batch job is not appearing the Query filters. If you run it manually then they appear. It happens with all, standard batch process and customize ones. Is there any parameter on the system that disables the query filters in the batch jobs?

     

    Thanks in advance.

     

    Kind regards,

    Laura


    0 0

    Hi,

    I am getting an error of Purhcase Order PONO123 updated by another user,though nobody else is using the same PO.

    Is it due to any set up parameters?

    Kindly suggest me the solution, I am badly requiring the wayout for this.

     


    0 0

    Hi to all,

    I would need a specific funcionality about Portugal Tax Authority, is the SAFT-Pt xml file.

    In AX 4.0 was a specific portuguese localization, but I don't find it for newest.

    Could somebody help me?


    0 0

    Hello all--

    I am developing a .NET web service in Visual Studio 2008 that makes use of the AX 4.0 Business Connector as a reference. (The host OS is XP SP3.)

    I am seeing some strange behavior when I attempt to re-point the business connector at a different AOS (for testing in dev, QA, production -- all 3 are backed by different databases and hosted on physically distinct machines). No change to the target AOS seems to occur at all, no matter what profile I use. To make it a bit more concrete:

    Step 1: I open the AX client configuration utility, choose "Business connector" at the top.

    Step 2: I select a pre-saved configuration for our dev server (let's call it AOSDEV).

    Step 3: I open Visual Studio, run my web service in debug mode, manually force a refresh on the Axapta object used by the service, and attempt a write operation. It succeeds as expected - the correct data is altered.

    Step 4: I close Visual Studio, and re-perform steps 1 and 2, instead choosing a profile for our QA server (let's call it AOSQA).

    Step 5: I repeat step 3, but, using the interactive Dynamics client, I see that the write operation I've performed has actually made a change to AOSDEV, and not AOSQA.

    Steps 4 and 5 are the same no matter what AOS I choose (aside from the dev instance) - the changes are written to the original AOSDEV.  I should mention that this behavior persists between reboots. 

    The only hitch I see here is the web service I'm debugging in VS impersonates an AD user dedicated to non-interactive Dynamics sessions. Running the AX client configuration utility as this user and altering the active profile doesn't solve this problem, however - apparently the business connector profiles are stored in HKLM in the registry, so all users see the same list from the same machine.

    In speaking with a lead dev here, he mentioned that occasionally he'll have to (on production IIS machines running the same web service code I'm debugging in VS) manually edit registry values to ensure this change happens.

    For others having similar problems: the correct keys to edit are in HKEY_USERS\.DEFAULT\Software\Microsoft\Dynamics\4.0\Configuration (search this tree for the aos hostname).

    This hack works for now, but... it's pretty far from ideal.

    Surely I'm missing something here, and the AX client configuration utility should in fact be changing the target AOS for the business connector...?

     Any and all help is very welcome, with thanks in advance.


    0 0

    Wondering how you pass a multi value parameter to a SSRS report in the AXReportViewer control?  I have tried passing it as a comma delimited string, but that doesn't seem to work.  Below is the code I am using to pass this information.  It is using the standard AddParameters method on the control.  It seems to work if i only pass a single value but passing a comma delimited list doesn't work.  Wondering if anyone has done this before or not. 

           Dictionary<string, object> parms = new Dictionary<string, object>();

           IAxContext axContext = AxContextHelper.FindIAxContext(this); ;

           parms.Add(BookedDateStartParamName, DateTime.Parse(this.TextboxFromDate.Text, axContext.CultureInfo).ToString("G"));

           parms.Add(BookedDateEndParamName, DateTime.Parse(this.TextboxToDate.Text, axContext.CultureInfo).ToString("G"));

           parms.Add(RegionParamName, RegionTextBox.Text);

           parms.Add(BranchParamName, BranchTextBox.Text);

           this.SalesBookingsReport.AddParameters(parms);


    0 0
  • 04/24/13--11:49: Item Master File
  • What is Item Master File in Dynamics AX?


    0 0

    When I export a report to Excel from Management Reporter, I have some subtotal rows that will not truncate the decimal places to the number of decimal places specified in the Row Definition or Column Definition or Report Definition. There will be a trail of zeros on the right side of the decimal place. This causes an error before the file opens in Excel. Excel recovers from the error. Excel opens the file and everything looks fine except for the rows where the decimal places are not truncated. Any ideas on this one? Thanks All.

    Noah


    0 0
  • 04/24/13--12:26: AX2012 R2 Upgrade
  • We are currently running AX2012 R1-CU3 and we are considering upgrading to AX2012 R2-CU1.  We have been told that the GL Reporting is much better but we have not been able to get any specific information on exactly what the improvements are.  Can anyone suggest where we can find this?  


    0 0

    Hi everyone!

    Recently I have noticed that remaining quantity of production BOM components is lowered when goods are reported as finished (error quantity not good quantity). As a result requirement for BOM components is decreased (but quantity of finished goods to be done is not!) and may lead to purchase or production of insufficient quantity of parts.

    Do you know how to fix this issue?

    Thanks in advance for all answers!

    PG


    0 0

    When I click the Search Customer button on the POS, then highlight the customer and click the Select button, I get an error.

    LSRetailPosis.POSProcesses.POSProcessThread: System.Data.SqlClient.SqlException (0x80131904): Invalid object name 'dbo.RETAILCUSTTRANSACTIONS'.

    I have tried deleting the POS database, and recreating it, but it didn't do anything. 

    Are there any settings I might be missing in core AX to get rid of this error?

    Thanks,

    Brandon


    0 0

    Dear All,

    I can not find the table to add to my profile in order to be able to delete a line of payment when i generate my payment proposal.

    Thanks in advance for your answers.

    Best regards

    Erwan


    0 0

    Hello,

    Maybe anyone could advice - in linensing model I've found 4 models, two of them are:

    - 'task cal' which may, between others, 'enter billable time', and

    - 'self service cal' which may, between others, 'make time and attendance entries such as registering hours, clock-in and clock-out'

    Need to estimate number of lincenses for regular employees, who will use EP for, between others, registering their time sheets - so can anyone confirm which license I would need for that? Will 'self service ca' be enough?

    regards

    Tomasz


    0 0
  • 04/24/13--03:50: How to hide an article
  • Hi all,

    I would like to know how I can hide some article so users can't see them in inventory management? I don't want to delete them, I just want to hide them.


    0 0

    Hi All,

     

    I've been generating several webservices in AX 2012 R2 and are able to consume them in Visual Studio.

    However, when i try to consume them in for example SOAPUI, nothing happens!

    Is maybe Microsoft using their own version of the SOAP-protocol?

    The problem is i'll have to consume them from a Java-environment.


    Has anyone experience with this kind of issues?

     

    Thanks!

     

    Barry

     

     

     


older | 1 | .... | 172 | 173 | 174 | (Page 175) | 176 | 177 | 178 | .... | 892 | newer